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Mozilla Firefox 4.0.1 
 
Introduction  

Mozilla Foundation, a nonprofit organization, provides the open-source Mozilla Firefox browser as a free 
download. Firefox 4.0.1 is currently configured in the Academic Computing labs for student use. To start 
Firefox on any computer, locate the Firefox icon and double-click to begin. 

Follow this link to see Firefox’s Keyboard Shortcuts. 
 

Understanding The Mozilla Firefox Interface   

 
Fig. 1 - Mozilla Firefox 4.0.1 

Menu Bar Tabs Navigation Bar Search Bar Bookmarks Sidebar 
Scroll Bar Display Content Status Bar  

Menu Bar 

The menu bar, located at the top of the browser window, gives access to and performs important specific 
functions that Firefox is capable of. The tools within the menu bar are those that you may use less 
frequently than those in other toolbars, but these items are vital to the browsers usability. 

Firefox 4.0’s default menu bar is set to a drop down menu. This can be accessed by clicking the orange 
Firefox button located in the top left corner of the page.  

 

http://www.mozilla.com/�
http://www.mozilla.com/�
http://www.mozilla.com/�
http://support.mozilla.com/en-US/kb/Keyboard%20shortcuts�
http://www.ryerson.ca/acs/usersguide/learning/images/mozilla_fullscreen.jpg�
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To switch from the drop-down format to the ribbon menu format: 

1. Click  in the top left corner 
2. Select Options 
3. Select Menu Bar 

To switch from the ribbon menu format to the drop-down format: 

1. Select View > Toolbars 
2. Uncheck Menu Bar 

**Note: Pressing Alt or F10 on your keyboard will display both menu options at the same time. 

Below is a summary of the most essential tools in the Menu Bar.  

Firefox Menu Bar Options 

File 

These commands allow you to perform vital actions such as opening and closing new Windows and 
Tabs. Selecting File > Print will print the current document to paper, and finally the Exit option will let 
you end your Firefox session. 

Edit 

Provides Copy, Paste and Find options. You can Select All text in a webpage by dragging the cursor 
over it. Then, click Edit > Copy to save the text to the Windows clipboard. In another application, 
choosing Edit > Paste will copy the text into the application. 

View 

Allows you to hide/show the toolbars, status bar, and sidebar. Provides options to customize a new 
toolbar. Text and page display can also be modified here. 

History 

Allows you to move forward, back or home. Also includes a list of recently viewed pages, tabs, 
windows. Selecting one of these will re-open that page. 

Bookmarks 

Bookmarking allows you to save page addresses to your browser for easy access. Once bookmarked, 
the pages are listed in this menu. Organizing bookmarks allows storage within folders. 
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Subscribing to a page allows you to use the browser to follow a Feed from pages with feeds/RSS 
enabled. 

Tools 

Options opens a window full of visual, security, and advanced settings. Essential for personalizing and 
tweaking your browser to your preference. 

Help 

Find assistance to browser problems. Use Check for Updates to keep your browser up-to-date with 
latest security and error fixes. Also offers help for regular Internet Explorer users. 

  

Toolbars 

The toolbars contain a number of buttons that may, depending on how Firefox is configured, appear with 
pictures, text, or pictures and text. Instead of using the menu, you can click on an icon to perform the same 
operation.  
 
By default, Firefox 4 has the Navigation toolbar permanently visible, and the Bookmarks toolbar available when 
the icon to the right of the screen is pressed.  

You can create new toolbars by accessing the Customize Toolbar window. There are two methods to do this.  

 

Fig. 2 – Customize Toolbar window 

http://www.ryerson.ca/acs/usersguide/learning/internet/glossary/index.html#feed�
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Method 1 –Menu Bar in drop-down format 

1. Click  in the top left corner 
2. Select Options 
3. Select Toolbar Layout… to display the Customize Toolbar window 

Method 2 – Menu Bar in ribbon format 

1. Select Click > Toolbars 
2. Select Customize… 

Once the Customize Toolbar window appears: 

1. You can add the icons onto the Navigation bar, or select the Add New Toolbar button to add a new 
row 

2. A popup will appear asking you to name your new toolbar 
3. Once you have named it, drag and drop necessary tool icons from the Customize Toolbar window and 

onto your new toolbar 
4. If you wish to remove a tool, drag and drop it from the toolbar and into the Customize Toolbar window 
5. Once you are happy with your arrangement, click Done 

**Note: The Customize Toolbar window also offers you the choice to Restore Default Set by clicking the 
button located in the bottom right corner. 

**Note: Clicking the Show drop down menu will change the display of tool buttons on the browser from icons 
to text format. 

Address Bar 
  

Firefox Navigation Toolbar Options 

 

Back 
Button 

Go back to the last document viewed. The button will be grayed out if you have only loaded one 
page. The back button can be used repeatedly to go back through all the pages viewed since 
the browser was opened. Right click on the icon so that a “history list” will drop down, allowing 
you to choose any previously visited web pages. 

  

Forward 
Button 

Go forward to the next document. The forward button is grayed out until you use the back 
button to view previously visited pages. Forward becomes useful when you have moved back 
through previously loaded pages and wish to move forward to more recently loaded ones. Right 
click on the icon for a list of previously viewed web pages. 

Bookmark 

 

Located in the Address Bar, this is used to bookmark the current page. Once clicked, the star 
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Page 
Button 

 

will turn yellow and name of the site will appear in the bookmarks list. Click the small arrow to 
the right for “history list” to drop down. Reclicking the button will display the bookmark editing 
window. 

  

 

Reload 
Button 

Reload the current page. Useful if there are problems loading a page and you are editing an 
HTML file on your workstation, and want to view changes you have made. Reload is also useful 
to see updates on a regularly updated page if you have been idle. 

  

 

Stop 
Button 

Stop (terminate) a connection if a site is taking too long to load. When a document is completely 
downloaded and displayed, the highlighted stop sign will turn into the Reload button. 

  

 

Home 
Button 

Home returns to Firefox's home page. You can edit what the home page is set to through the 
Tools menu. By default, in most of the labs, this is set to the my.ryerson portal. 

 

 
Display 

Bookmarks 
Button  

 

 

Clicking this will produce a dropdown menu with options to View Bookmarks Toolbar, edit the 
toolbar, view Recently Bookmarked pages, etc. 

 

Sidebar 
 

Sidebar displays bookmarks or history. Click View >Sidebar and choose between the Bookmarks or History 
sidebars. 

Bookmarks Menu 
 

The bookmarks sidebar is where you will find the pages and folders you 
have previously bookmarked. Get quick access to this sidebar with 
CTRL+B. To choose a site that has been previously saved in your 
bookmark file folders, open the Bookmarks tab on the sidebar or click the 
Bookmarks menu. Select the name of the website you would like to go to 
and the page will display.  

http://www.ryerson.ca/acs/usersguide/learning/internet/firefox/#tools�
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History Menu 
 

Bring up this sidebar with CTRL+H. History keeps track of all the sites that 
you have visited. Sites are organized into folders according to the day 
they were visited. Expand the folder of a day to see the list of websites 
you visited on that day. Click on the page to open it. You can change your 
History settings by clicking Tools > Options > Privacy.  

To delete your history, which frees up space on your hard drive, select 
Tools > Clear Recent History. 

Search Bar  

To the right of your address bar, you will see a smaller text field. This is your Search Bar. This feature allows 
you to use a search engine without having to first navigate to the search engine website. Entering keywords in 
the Search Bar performs the same action as entering those keywords on the search engine page. The Search 
Bar is a quick and efficient way to make use of search engines. To learn how to configure your search bar, visit 
the Search Engine page.  

 

Tabbed Browsing  

This feature is useful for viewing multiple web pages in one browser window. There are several ways in which 
to open a new tab. To switch the window you are viewing, simply click on the tab name. This avoids having to 
open many browser windows to view different sites. To close a tab, click the X on the right side of the tab’s 
heading. When a site is loading, the left side of the tab will have a green loading icon indicating that the page is 
loading. 

To open a new tab window, you can use any of the following methods: 

1. If you are using the drop-down Menu Bar, select > New Tab > New Tab 
2. If you are using the ribbon Menu Bar, click File > New Tab 
3. Press CTRL + T on your keyboard 
4. Click the small, square stub-tab with the + located to the right of your last tab 

http://www.ryerson.ca/acs/usersguide/learning/internet/search/index.html#searchbar�
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Fig. 3 - Tabs as seen in Firefox 4.0.1 

**Note: The small, downwards pointing arrow at the end of the tab bar will display the tabs in list form. 

Security  

As you “surf” the internet with your browser, websites deposit small files called cookies to track your internet 
usage. Additionally your browser collects passwords and various other files from you and the internet as you 
browse. In order to ensure your browser is secure, it should be configured to delete private data each time you 
exit. 

 
To setup this function in Firefox: 

• Click Tools (at the top of your browser window) 
• Options> Click the Privacy Icon 
• Select the drop-down menu beside the Firefox will heading 
• Select Use custom settings for history 
• Check the box that says “Clear history when Firefox closes” 
• Click OK 

Your browser will now clear any history, cashed files, cookies and stored passwords, each time you exit. 

Erasing this data is especially important on a shared computer that other people will be frequently using. When 
prompted to save a password, always select No when on a shared computer. Computers at Ryerson 
automatically erase this data after you log off to prevent other users from gaining access to your accounts. 

Feeds  

Feeds are similar to bookmarks, but instead of just saving the web address for a site, a feed constantly 
updates with links to the latest content on that site. Feeds essentially provide you with headlines from each of 
your favourite sites without having to visit each individually, simply clicking the headline will bring you directly to 
that article. 
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Fig. 4 - A feed menu in Firefox 4.0.1 

Firefox includes a Latest Headlines feed by default which is located in the Bookmarks Bar/Menu. Selecting 
this will open a drop-down menu that constantly updates with latest news headlines (see above). You may 

subscribe to your own feeds by locating the Feed icon  on a webpage.  

**Note: not all websites have feeds, so don't worry if you can't find the icon.   

Status Bar 

The last line on the window is reversed for messages. If you hover your mouse over a link on the webpage, a 
small box (the status bar) will appear at the bottom of the window, indicating the destination of the link.  

Scroll Bar  

To the right of the document area is a scroll bar that allows you to move a display up or down. (See the 
example image to the right). Point the mouse to any location on the bar, click and the display moves 
accordingly. To move the display more slowly, position the cursor on the top or bottom arrow on the bar 
and click. You can also drag the "elevator" button that moves in the scroll bar to move to any place in the 
document. Sometimes, depending on the current web page and the size of the browser window that you are 
viewing it in, there is also a horizontal scroll bar located at the bottom of the window that moves left and right.  

Display Content  

Loaded web pages are displayed just below the tab bar. Web pages can include text and graphics. Some sites 
also provide animation and video [With slower Internet connections, these features will take longer to appear 
on the page and play]. To view these, click on them. To hear any of the sound options provided, your PC must 
have speakers and the appropriate hardware and software installed. Your internet connection speed will 
determine how quickly these pages display. 

http://www.ryerson.ca/acs/usersguide/learning/internet/firefox/#bookmarks�
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